« GmlMgrの範囲指定データ | トップページ | GmlMgr 1.00 »

GmrMgrのインストール

前提条件として、当然GM_Liteをインストールされていることとし、以下の説明ではGM_Liteはgm_liteというフォルダにインストールされていることとします。
またperlもインストールしてください。Windowsの方ならActivePerlの使用がお勧めです。

GmlMgrをダウンロードしたファイルを展開するとできるgmlmgrフォルダを、まるごとgm_lite直下においてください(現在直下でないとうまく動きません)。その中に実行ファイルが入っています。

実行はWindowsにActivePerlをインストールしているなら、.plファイルには関連付けがされているはずなので、目的のコマンドをクリックするだけでいいはずです。
それ以外の方は、おそらく自分でなんでもできる方でしょう。

ただし…

いくつかのプログラムではPerlの標準パッケージに入っていないモジュールを使っています。
現在配布されているActivePerlに標準で入っていることは確認済みですが、もし、モジュールが足りないというエラーが出た方はCPANなどから取得してください。

なお、各コマンドはGmlMgr.pmというモジュールを使っているので、コマンドラインではgmlmgrフォルダからしか実行できません。

なお、ディスクイメージの作成は、もちろんGM_Lite付属のmkisofs.exeを使用しても可能ですが、(私のようにGM_Lite付属の)CygWin環境では困るという方は、Windowsネイティブバイナリを入手しgmlmgrディレクトリにおいてください(詳細)。

|

« GmlMgrの範囲指定データ | トップページ | GmlMgr 1.00 »

GM_Lite」カテゴリの記事

コメント

WindowsXpの環境で、
ActivePerl-5.10.0をインストールし、
GM_Lite0.1.4を使って、Cドライブの直下に展開されたgm_liteフォルダ丸ごとをコピーしました。
また、こちらのサイトで頂戴したGmlMgr 1_01を展開し得られたgmlmgrフォルダをgm_liteフォルダ直下に置きました。

 gmlmgrフォルダの中にあるdown_maps.plをダブルクリックしても次のような画面がでて、0バイトの画像が増えてしまいます。

read japan.dat
read world.dat
download image data
21514 target images
Google Maps version is unknown
Error at z=13 x=57 y=22 img=imgs/13/00/00/00/00/00/00/00/00/52/72.png
Error at z=13 x=56 y=23 img=imgs/13/00/00/00/00/00/00/00/00/52/63.png
...


私がまだ何か見落として手落ちがあるのでしょうか?
Googleが対策を打ってしまったのでしょうか?
いろいろと試しているのですが、解決に至りません。

すでに成功した経験のある方で、ダウンロードを試すと同じエラーが出ますでしょうか?

何とぞヒントをください。


投稿: | 2009年6月27日 (土) 15時21分

すみません。先ほど書き込みしたものです。

ほぼ9割以上エラーばかりで0バイトが増えていくのですが、
エラーを気にせず数時間くらい走らせていたら、たまにsuccessの表示が出て確かにpng画像が落とせているようです。
皆さんもこんな感じなんでしょうか?


・・・
error: 8, 1828, 732, imgs/08/00/00/00/00/00/00/10/87/23/82.png
success: 8, 1828, 733, imgs/08/00/00/00/00/00/00/10/87/23/83.png
error: 8, 1828, 734, imgs/08/00/00/00/00/00/00/10/87/23/84.png
error: 8, 1828, 735, imgs/08/00/00/00/00/00/00/10/87/23/85.png
・・・

投稿: 小僧 | 2009年6月27日 (土) 17時40分

参考になるかわかりませんが・・・
今、ちょっとやってみた感じでは、上手く出来ましたよ
GmlMgr 1_01で普通に縮尺7から2までダウンロードできました。
(東北地方のとある県の内陸部でテスト)
logは全部successって出てますね。
0バイトのpng画像はありませんでした。
ちなみに私のActiveperlは5.8.6です。

投稿: BK | 2009年7月 1日 (水) 01時56分

しばらく放置していました。すみません。

原因がそれかは分かりませんが、Google Mapsのバージョンがずいぶん上がっていたようで、古いものではもうダウンロードできないようです。
1.03を作りましたので、そちらを試していただけますか。

投稿: waste | 2009年7月17日 (金) 09時25分

コメントを書く



(ウェブ上には掲載しません)




トラックバック


この記事へのトラックバック一覧です: GmrMgrのインストール:

« GmlMgrの範囲指定データ | トップページ | GmlMgr 1.00 »